您的位置:首页 > 其它

HDOJ-1241 Oil Deposits

2016-07-28 21:12 375 查看

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24541    Accepted Submission(s): 14094

[align=left]Problem Description[/align]
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

 

[align=left]Input[/align]
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

 

[align=left]Output[/align]
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

 

[align=left]Sample Input[/align]

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

 

[align=left]Sample Output[/align]

0
1
2
2

 
介个题好难,a了半天还不对,测试样例以及自己写的都对,就是不AC,好像是网页出BUG了(简直日了dog)。用DFS/BFS都可以。
DFS代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <queue>
using namespace std;
char map[110][110];
int vis[110][110];
int m,n,ans;
int fx[8]={1,1, 1,0, 0,-1,-1,-1};
int fy[8]={1,0,-1,1,-1, 1, 0,-1};
void f(int x,int y)
{
for(int i=0;i<8;i++)
{
int dx=x+fx[i],dy=y+fy[i];
if(vis[dx][dy]==1&&dx>=0&&dx<n&&dy>=0&&dy<m)
{
vis[dx][dy]=0;
f(dx,dy);
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m)&&n||m)
{
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)
{
getchar();
for(int j=0;j<m;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='@') vis[i][j]=1;
}
}
ans=0;
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(vis[i][j]==1)
{
ans++;
f(i,j);
}
}
}
printf("%d\n",ans);
}
return 0;
}


BFS代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <climits>
#include <queue>
using namespace std;
struct node{
int x,y;
};
char map[110][110];
int vis[110][110];
int m,n,ans;
int fx[8]={1,1, 1,0, 0,-1,-1,-1};
int fy[8]={1,0,-1,1,-1, 1, 0,-1};
void BFS(node s)
{
vis[s.x][s.y]=0;
queue<node > q;
q.push(s);
while(!q.empty())
{
node now=q.front();
q.pop();
for(int i=0;i<8;i++)
{
node next;
next.x=now.x+fx[i];
next.y=now.y+fy[i];
if(vis[next.x][next.y]==1&&next.x>=0&&next.x<n&&next.y>=0&&next.y<m)
{
vis[next.x][next.y]=0;
q.push(next);
}
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m)&&n||m)
{
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++)
{
getchar();
for(int j=0;j<m;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='@') vis[i][j]=1;
}
}
ans=0;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(vis[i][j]==1){
node s;
s.x=i;s.y=j;
ans++;
BFS(s);
}
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: