您的位置:首页 > 其它

Red and Black hd 1312

2016-07-28 20:53 330 查看
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9

....#.

.....#

......

......

......

......

......

#@...#

.#..#.

11 9

.#.........

.#.#######.

.#.#.....#.

.#.#.###.#.

.#.#..@#.#.

.#.#####.#.

.#.......#.

.#########.

...........

11 6

..#..#..#..

..#..#..#..

..#..#..###

..#..#..#@.

..#..#..#..

..#..#..#..

7 7

..#.#..

..#.#..

###.###

...@...

###.###

..#.#..

..#.#..

0 0

Sample Output

45

59

6


13

#include<stdio.h>
#include<iostream>
using namespace std;
int n,m,dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}},sum;
char map[25][25];

int DFS(int i,int j)
{
int e;
map[i][j]='#';
sum++;
for(e=0;e<4;e++)
if(i+dir[e][0]>=0&&i+dir[e][0]<n&&j+dir[e][1]>=0&&j+dir[e][1]<m)
if(map[i+dir[e][0]][j+dir[e][1]]!='#')
DFS(i+dir[e][0],j+dir[e][1]);
}

int main()
{
int i,j,pi,pj;
while(scanf("%d%d",&m,&n)>0&&(m||n))
{
for(i=0;i<n;i++)
{
getchar();
for(j=0;j<m;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='@')
{
pi=i;pj=j;
}
}
}
sum=0;
DFS(pi,pj);
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: