您的位置:首页 > 理论基础 > 数据结构算法

2116数据结构实验之链表一:顺序建立链表

2016-07-28 16:28 369 查看


数据结构实验之链表一:顺序建立链表


Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

输入N个整数,按照输入的顺序建立单链表存储,并遍历所建立的单链表,输出这些数据。

输入

第一行输入整数的个数N;

第二行依次输入每个整数。

输出

输出这组整数。

示例输入

8
12 56 4 6 55 15 33 62


示例输出

12 56 4 6 55 15 33 62


提示

不得使用数组!

来源

#include<stdio.h>

#include<stdlib.h>

struct node{

    int data;

    struct node *next;

};

int main()

{

    struct node *head,*p,*q,*tail;

    int i,n;

    scanf("%d",&n);

    head=(struct node *)malloc(sizeof(struct node));

    head->next=NULL;

    tail=head;

    while(n--)            /*第一个插入的结点为第一个结点,然后依次往后插入结点 */

    {

        p=(struct node *)malloc(sizeof(struct node));

        scanf("%d",&p->data);

        p->next=NULL;

       tail->next=p;

       tail=p;               /*p结点已达到链表结尾*/

    }

    p=head->next;         /*重新遍历应该从头开始*/

    while(p!=NULL)

    {

        if(p->next!=NULL)

            printf("%d ",p->data);

        else printf("%d\n",p->data);

        p=p->next;

    }

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: