您的位置:首页 > 其它

poj2686(Traveling by Stagecoach)状态压缩dp+DAG

2016-07-28 13:00 330 查看
Traveling by Stagecoach

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 2894 Accepted: 1053 Special Judge
Description

Once upon a time, there was a traveler. 

He plans to travel using stagecoaches (horse wagons). His starting point and destination are fixed, but he cannot determine his route. Your job in this problem is to write a program which determines the route for him. 

There are several cities in the country, and a road network connecting them. If there is a road between two cities, one can travel by a stagecoach from one of them to the other. A coach ticket is needed for a coach ride. The number of horses is specified in
each of the tickets. Of course, with more horses, the coach runs faster. 

At the starting point, the traveler has a number of coach tickets. By considering these tickets and the information on the road network, you should find the best possible route that takes him to the destination in the shortest time. The usage of coach tickets
should be taken into account. 

The following conditions are assumed. 
A coach ride takes the traveler from one city to another directly connected by a road. In other words, on each arrival to a city, he must change the coach. 

Only one ticket can be used for a coach ride between two cities directly connected by a road. 

Each ticket can be used only once. 

The time needed for a coach ride is the distance between two cities divided by the number of horses. 

The time needed for the coach change should be ignored.

Input

The input consists of multiple datasets, each in the following format. The last dataset is followed by a line containing five zeros (separated by a space). 

n m p a b 

t1 t2 ... tn 

x1 y1 z1 

x2 y2 z2 

... 

xp yp zp 

Every input item in a dataset is a non-negative integer. If a line contains two or more input items, they are separated by a space. 

n is the number of coach tickets. You can assume that the number of tickets is between 1 and 8. m is the number of cities in the network. You can assume that the number of cities is between 2 and 30. p is the number of roads between cities, which may be zero. 

a is the city index of the starting city. b is the city index of the destination city. a is not equal to b. You can assume that all city indices in a dataset (including the above two) are between 1 and m. 

The second line of a dataset gives the details of coach tickets. ti is the number of horses specified in the i-th coach ticket (1<=i<=n). You can assume that the number of horses is between 1 and 10. 

The following p lines give the details of roads between cities. The i-th road connects two cities with city indices xi and yi, and has a distance zi (1<=i<=p). You can assume that the distance is between 1 and 100. 

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.
Output

For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces. 

If the traveler can reach the destination, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that
the above accuracy condition is satisfied. 

If the traveler cannot reach the destination, the string "Impossible" should be printed. One cannot reach the destination either when there are no routes leading to the destination, or when the number of tickets is not sufficient. Note that the first letter
of "Impossible" is in uppercase, while the other letters are in lowercase. 

Sample Input
3 4 3 1 4
3 1 2
1 2 10
2 3 30
3 4 20
2 4 4 2 1
3 1
2 3 3
1 3 3
4 1 2
4 2 5
2 4 3 4 1
5 5
1 2 10
2 3 10
3 4 10
1 2 0 1 2
1
8 5 10 1 5
2 7 1 8 4 5 6 3
1 2 5
2 3 4
3 4 7
4 5 3
1 3 25
2 4 23
3 5 22
1 4 45
2 5 51
1 5 99
0 0 0 0 0

Sample Output
30.000
3.667
Impossible
Impossible
2.856

Hint

Since the number of digits after the decimal point is not specified, the above result is not the only solution. For example, the following result is also acceptable. 

30.0

3.66667

Impossible

Impossible

2.85595


这题也是状态压缩dp,把一张车票是否已用看成一种状态,可以用二进制编码去用整数实现这一状态的表示。考虑现在在城市v,此时还剩下的车票的集合为S的状态,从这个状态出发,使用一张车票i(i属于S),到达相邻的城市u,就相当于转移到这样的状态“现在在城市u,此时还剩下的车票的集合为S\{i}”。把这个转移看成一条边,边上的花费为d[v][u]/t[i],按照这个方法就可以用普通的Dijkstra算法求解了,不过这个图是一个DAG,计算DAG的最短路径直接使用动态规划就可以啦。下面是AC代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define INF 0x7fffffff
#define min(a,b) (a<b)?a:b
int d[35][35];//-1表示没有边
int t[10];
//dp[S][v]表示到达剩下的车票集合为S并且现在所在城市为v的状态所需要的最小花费
double dp[1<<10][35];
//n表示车票的数量,m表示城市的数量,p表示道路的数量,a表示起始城市,b表示目的城市
int n,m,p,a,b;
void solve()
{
for(int i=0;i<(1<<n);i++){
fill(dp[i],dp[i]+m,INF);
}
dp[(1<<n)-1][a-1]=0;
double res=INF;
for(int S=(1<<n)-1;S>=0;S--){
res=min(res,dp[S][b-1]);
for(int v=0;v<m;v++){
for(int i=0;i<n;i++){
if((S>>i)&1){
for(int u=0;u<m;u++){
if(d[v][u]>=0){
dp[S&~(1<<i)][u]=min(dp[S&~(1<<i)][u],dp[S][v]+(double)d[v][u]/t[i]);
}
}
}
}
}
}
if(res==INF){
printf("Impossible\n");//无法到达
}
else{
printf("%.3f\n",res);
}
}
int main()
{
while(cin>>n>>m>>p>>a>>b){
if(n==0&&m==0&&p==0&&a==0&&
4000
amp;b==0){
break;
}
for(int i=0;i<n;i++){
cin>>t[i];
}
memset(d,-1,sizeof(d));
for(int i=0;i<p;i++){
int x,y,z;
cin>>x>>y>>z;
d[x-1][y-1]=z;
d[y-1][x-1]=z;
}
solve();
}
return 0;
}
好烦啊,最近感觉智商不够用。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息