您的位置:首页 > 其它

【POJ】[3176]Cow Bowling

2016-07-28 09:56 281 查看

Cow Bowling

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 17309Accepted: 11558

Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:
7

3   8

8   1   0

2   7   4   4

4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5


Sample Output

30


Hint

Explanation of the sample:
7

*

3   8

*

8   1   0

*

2   7   4   4

*

4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.

经典dp问题

从下面向上有

dp[i][j]+=max(dp[i+1][j],dp[i+1][j+1])

所以最后结果就会是dp[0][0]

#include<stdio.h>
#include<algorithm>
using namespace std;
int map[352][352];
int main() {
int n;
while(scanf("%d",&n)!=EOF) {
for(int i=0; i<n; i++)
for(int j=0; j<=i; j++)
scanf("%d",&map[i][j]);
if(n==1) {
printf("%d\n",map[0][0]);
continue;
}
for(int i=n-2; i>=0; i--) {
for(int j=0; j<=i; j++) {
map[i][j]+=max(map[i+1][j],map[i+1][j+1]);
}
}
printf("%d\n",map[0][0]);
}
return 0;
}


题目地址:【POJ】[3176]Cow Bowling

查看原文:http://www.boiltask.com/blog/?p=1447
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: