您的位置:首页 > 其它

hdu 1498(最小点覆盖集)

2016-07-27 23:18 369 查看

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2256 Accepted Submission(s): 1266


[align=left]Problem Description[/align]
On
Octorber 21st, HDU 50-year-celebration, 50-color balloons floating
around the campus, it's so nice, isn't it? To celebrate this meaningful
day, the ACM team of HDU hold some fuuny games. Especially, there will
be a game named "crashing color balloons".

There will be a n*n
matrix board on the ground, and each grid will have a color balloon in
it.And the color of the ballon will be in the range of [1, 50].After the
referee shouts "go!",you can begin to crash the balloons.Every time you
can only choose one kind of balloon to crash, we define that the two
balloons with the same color belong to the same kind.What's more, each
time you can only choose a single row or column of balloon, and crash
the balloons that with the color you had chosen. Of course, a lot of
students are waiting to play this game, so we just give every student k
times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.



[align=left]Input[/align]
There
will be multiple input cases.Each test case begins with two integers n,
k. n is the number of rows and columns of the balloons (1 <= n <=
100), and k is the times that ginving to each student(0 < k <=
n).Follow a matrix A of n*n, where Aij denote the color of the ballon in
the i row, j column.Input ends with n = k = 0.

[align=left]Output[/align]
For
each test case, print in ascending order all the colors of which are
impossible to be crashed by a student in k times. If there is no choice,
print "-1".

[align=left]Sample Input[/align]

1 1
1
2 1
1 1
1 2
2 1
1 2
2 2
5 4
1 2 3 4 5
2 3 4 5 1
3 4 5 1 2
4 5 1 2 3
5 1 2 3 4
3 3
50 50 50
50 50 50
50 50 50
0 0

[align=left]Sample Output[/align]

-1
1
2
1 2 3 4 5
-1

题意:给出一个矩阵,里面有一些颜色不同的气球,一次能够消灭一行或者一列的气球,问某一种颜色的气球能否在 k 次内消除完毕,如果不能则输出气球颜色编号,如果全部可以则输出-1.
题解:最小点覆盖问题,枚举每一种颜色的气球,然后对每一个做一次最大匹配,如果最大匹配>k,则不能够消灭.时间复杂度O(n^3) ,这都能在62MS跑过去,数据太水。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include <algorithm>
#include <math.h>
using namespace std;
const int N = 105;
int n,k;
int graph

,graph1

;
int linker
,result
;
bool vis
;
int Hash[55];
bool dfs(int u){
for(int v=0;v<n;v++){
if(graph1[u][v]&&!vis[v]){
vis[v] = true;
if(linker[v]==-1||dfs(linker[v])){
linker[v] = u;
return true;
}
}
}
return false;
}
int main()
{
while(scanf("%d%d",&n,&k)!=EOF){
if(n==0&&k==0) break;
memset(Hash,0,sizeof(Hash));
for(int i=0;i<n;i++){
for(int j=0;j<n;j++){
scanf("%d",&graph[i][j]);
Hash[graph[i][j]] = 1;
}
}
int m = 0;
for(int i=1;i<=50;i++){
if(!Hash[i]) continue;
memset(graph1,0,sizeof(graph1));
memset(linker,-1,sizeof(linker));
for(int j=0;j<n;j++){
for(int k=0;k<n;k++){
if(graph[j][k]==i) {
graph1[j][k] = 1;
}
}
}
int res = 0;
for(int u=0;u<n;u++){
memset(vis,0,sizeof(vis));
if(dfs(u)) res++;
}
if(res>k) result[m++] = i;
}
if(m==0){
printf("-1\n");
continue;
}
for(int i=0;i<m-1;i++){
printf("%d ",result[i]);
}
printf("%d\n",result[m-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: