您的位置:首页 > 其它

hdu 1068 Girls and Boys(最大独立集模板)

2016-07-27 22:21 441 查看


Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10501    Accepted Submission(s): 4850


Problem Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying
the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students

the description of each student, in the following format

student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...

or

student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.

For each given data set, the program should write to standard output a line containing the result.

 

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

 

Sample Output

5
2

题意:班里有n个人,先从第0个人到第n-1个人给出有缘分的人,求最大的没有缘分集合。即集合内任意两个人都是没缘分的

思路:模板题,最大独立集。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
#define N 510
#define INF 999999999
int ma

;
int n,line
,vis
;
struct Node
{
char c,d;
int x,y;
} p
;
int can(int t)
{
for(int i=1; i<=n; i++)
{
if(i==t)continue;
if(!vis[i]&&ma[t][i])
{
vis[i]=1;
if(line[i]==-1||can(line[i]))
{
line[i]=t;
return 1;
}
}
}
return 0;
}
int main()
{
int T,s,num;
while(~scanf("%d",&n))
{
memset(ma,0,sizeof(ma));
memset(line,-1,sizeof(line));
for(int i=1;i<=n;i++)
{
scanf("%d: (%d)",&s,&num);
while(num--)
{
scanf("%d",&s);
ma[i][s+1]=1;
}
}
int ans=0;
for(int i=1; i<=n; i++)
{
memset(vis,0,sizeof(vis));
if(can(i)) ans++;
}
printf("%d\n",n-ans/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: