您的位置:首页 > 其它

UVA 10566 Crossed Ladders (几何+二分)

2016-07-27 20:12 288 查看
Description

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the
base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?





Input

Input starts with an integer T (≤ 10), denoting the number of test cases.

Each test case contains three positive floating point numbers giving the values of x, y, and c.

Output

For each case, output the case number and the width of the street in feet. Errors less than 10-6 will be ignored.

Sample Input

4

30 40 10

12.619429 8.163332 3

10 10 3

10 10 1

Sample Output

Case 1: 26.0328775442

Case 2: 6.99999923

Case 3: 8

Case 4: 9.797958971

代码如下:

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
double x,y,c,mid;
double judge(double w)
{
return 1-c/sqrt(x*x-w*w)-c/sqrt(y*y-w*w);

}
int main()
{
int n;
scanf("%d",&n);
int ant=1;
while(n--)
{

scanf("%lf%lf%lf",&x,&y,&c);
printf("Case %d: ",ant++);
double r,l;
r=min(x,y);
l=0;
while(l+1e-9<r)
{
mid=(l+r)/2;
if(judge(mid)>0)
l=mid;
else
r=mid;
}
printf("%.6lf\n",l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: