您的位置:首页 > 其它

poj 1611 The Suspects(并查集)

2016-07-27 19:12 435 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 33063 Accepted: 16027
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1


以前学的并查集是光能判断谁不是连通的,独立的,但这个题要求求与0相连通的点有几个。
题意大体就是学生分为若干个团体,一个团体中一个学生有嫌疑,整个团体都有嫌疑,假设0号学生有嫌疑,求有多少个学生有嫌疑,应该可能就是这样...

并查集模板
</pre><pre name="code" class="cpp">int pre[31000],num[31000];//pre记录祖先num记录以这个点为祖先的孩子有几个
int Find(int x) //找祖先
{
if(x!=pre[x])
pre[x]=Find(pre[x]);
return pre[x];
}
void mix(int x,int y)
{
x=Find(x);
y=Find(y);
if(x!=y)
{
pre[x]=y;
num[y]+=num[x];
}
}

AC代码

/*并查集*/
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int pre[31000],num[31000];//pre记录祖先num记录以这个点为祖先的孩子有几个
int Find(int x)
{
if(x!=pre[x])
pre[x]=Find(pre[x]);
return pre[x];
}
void mix(int x,int y)
{
x=Find(x);
y=Find(y);
if(x!=y)
{
pre[x]=y;
num[y]+=num[x];
}
}
int main()
{
int n,m,i,j;
int k,l,t;
while(scanf("%d%d",&n,&m)&&(n||m))
{
for(i=0;i<n;i++)
{
num[i]=1;
pre[i]=i;
}
while(m--)
{
scanf("%d",&t);
if(t>0)
{
scanf("%d",&l);
for(i=1;i<t;i++)
{
scanf("%d",&k);
mix(l,k);
}
}
}
l=Find(0);
printf("%d\n",num[l]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: