您的位置:首页 > 其它

poj 3678 Labeling Balls

2016-07-27 15:04 363 查看
题目链接:点击打开链接

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

No two balls share the same label.
The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".
Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two
integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label
2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input
5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output
1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

题目大意:给出球的颜色的轻重不一样的n 个,用1-n表示,做标签时是有先后顺序的,给出m对先后的限制条件.按字典序输出先后的顺序
基本思路:逆序拓扑排序.以为题目要求要按照字典序列输出(拓扑排序有多种输出结果,一般我们是按n的先后遍历时输出的),并且这里要借助优先队列而不是队列
<span style="font-size:18px;">#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<cstring>
#include<queue>

using namespace std;
using namespace std;
int de[210];
int mp[210][210];
priority_queue<int >q;//优先队列
int main()
{
int t;
cin>>t;
int n,m;

while(t--)
{
memset(de,0,sizeof(de));
memset(mp,0,sizeof(mp));
cin>>n>>m;
int x,y;
for(int i=0; i<m; i++)
{
cin>>x>>y;
if(mp[x][y]==1)de[x]--;//判断是否重边
de[x]++;//逆向建图
mp[x][y]=1;
}
while(!q.empty())
{
q.pop();
}
int a[210];
for(int i=1; i<=n; i++)
{
if(de[i]==0)
{
q.push(i);
}
}
int k=n;
while(!q.empty())
{
int temp=q.top();
a[temp]=k--;//存储要输出的拓扑排序
q.pop();
for(int i=1; i<=n; i++)
{
if(mp[i][temp]==1)
{
mp[i][temp]=0;
de[i]--;
if(de[i]==0)
{
q.push(i);
}
}
}
}
if(k!=0)printf("-1\n");
else
{
for(int i=1; i<=n; i++)
{
if(i==1)printf("%d",a[i]);
else printf(" %d",a[i]);
}
printf("\n");
}
}
return 0;
}
</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: