您的位置:首页 > 其它

【POJ】2503 - Babelfish(STL)

2016-07-27 14:49 357 查看
点击打开题目

Babelfish

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 40350 Accepted: 17188
Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears
more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output
cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.
Source

Waterloo local 2001.09.22

纯纯的 STL 之string、map 的应用题。

在读入数据方面要注意,我不是很会用C++的输入输出流,方法比较笨。

代码如下:

#include <cstdio>
#include <map>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
int main()
{
map<string,string> dic;
string a,b;
char t;
char temp[22];
while (t = getchar())
{
if (t == '\n')
break;
a.clear();
a += t;
scanf ("%s",temp);
a += temp;
scanf ("%s",temp);
b.clear();
b += temp;
dic[b] = a;
getchar();
}
while (~scanf ("%s",temp))
{
a.clear();
a += temp;
if (dic[a] != "")
cout << dic[a] << endl;
else
cout << "eh" << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: