您的位置:首页 > 其它

poj 1573 Robot Motion

2016-07-27 14:40 387 查看
题目链接:点击打开链接

Description



A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 

S south (down the page) 

E east (to the right on the page) 

W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.
Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.
Sample Input
3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output
10 step(s) to exit
3 step(s) before a loop of 8 step(s)

题目大意:给出地图的大小和开始的列坐标,图中的字母为方向,东西南北.判断从开始能不能走出地图,或是在图中循环,如果走出地图,输出步数,否则输出循环之前的步数和循环的步数.

基本思路:模拟地图,每一步判断一下,并且走过的位置做好标记.我卡在了条件判断那,没有加else 执行的时候会重复

#include <iostream>
#include<cstring>
#include<cstdlib>
#include<cstdio>
using namespace std;
struct node
{
int step;
char ch;
int vis;
} mp[20][20];
int main()
{
int n,m;
int x,y;
while(cin>>n>>m>>y,n&&m&&y)
{
y=y-1;
x=0;
char str[20][20];
for(int i=0;i<n;i++)
{
cin>>str[i];
}
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
mp[i][j].ch=str[i][j];
mp[i][j].step=0;
mp[i][j].vis=0;
}
}
int step=0;
int f=0;
int t,p;
while(1)
{
if(mp[x][y].vis==1)
{
t=mp[x][y].step;
p=step-t;
break;
}
else if(mp[x][y].ch=='N')
{
mp[x][y].step=step++;
mp[x][y].vis=1;
x--;
if(x<0)
{
f=1;
break;
}
}
else if(mp[x][y].ch=='E')
{

mp[x][y].step=step++;
mp[x][y].vis=1;
y++;
if(y>=m)
{
f=1;
break;
}
}
else  if(mp[x][y].ch=='S')
{
mp[x][y].step=step++;
mp[x][y].vis=1;
x++;
if(x>=n)
{
f=1;
break;
}
}
else if(mp[x][y].ch=='W')
{
mp[x][y].step=step++;
mp[x][y].vis=1;
y--;
if(y<0)
{
f=1;
break;
}
}
}
if(f==1)
{
printf("%d step(s) to exit\n",step);
}
else
{

printf("%d step(s) before a loop of %d step(s)\n",t,p);

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: