您的位置:首页 > 其它

H - Pie

2016-07-27 10:25 253 查看

H - Pie

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:

—One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.

—One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3

3 3

4 3 3

1 24

5

10 5

1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327

3.1416

50.2655

题意:给你几块蛋糕,平均分给几个人,问每人得到的最大值。(每人只能一块,即不能用小蛋糕拼)

思路:用二分法在区间内枚举平均蛋糕最大值,然后判断是否符合题意。

失误;没看懂呀。

代码如下:

#include<iostream>
#include<cstdio>
#include<cmath>
#define PI acos(-1)
#define esp 1e-9
const int MAXN=1e7+10;

double a[MAXN];
double tem,right,left,mid,s;
int f,n;
bool judge(double mid)
{
int s=0,i;
for(i=1;i<=n;++i)
{
s+=(int)(a[i]/mid);
}
return s>=f;
}

int main()
{
int t,i,cnt;

scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&f);++f;
s=0.0;
for(i=1;i<=n;++i)
{
scanf("%lf",&a[i]);
a[i]=a[i]*a[i]*PI;//没想到
s+=a[i];
}
left=0.0;right=s;
cnt=100;
while(cnt--)
{
mid=(left+right)/2.0;
if(judge(mid))
{
left=mid+esp;
}
else
{
right=mid-esp;
}

}
printf("%.4lf\n",mid);//误差三位 精确到4位
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: