您的位置:首页 > 理论基础 > 数据结构算法

数据结构上机测试2-1:单链表操作A

2016-07-27 10:08 316 查看


数据结构上机测试2-1:单链表操作A




Time Limit: 1000ms   Memory limit: 4096K  有疑问?点这里^_^



题目描述

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。


输入

第一行输入数据个数n;

第二行依次输入n个整数;

第三行输入欲删除数据m。


输出

第一行输出原始单链表的长度;

第二行依次输出原始单链表的数据;

第三行输出完成删除后的单链表长度;

第四行依次输出完成删除后的单链表数据。


示例输入

10
56 25 12 33 66 54 7 12 33 12
12



示例输出

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33


这道题就是顺序建链表并且删除相同的元素。但是应当注意第一个和最后一个的删除。
#include<stdio.h>
#include<iostream>
using namespace std;
int n;
struct node
{
int  d;
node *next;
};

node *CreatList(int n)      //顺序建表
{
node *head=new node;
head->next=NULL;
node *tail=head;
for(int i=0;i<n;i++)
{
node *p=new node ;
cin>>p->d;
tail->next=p;
tail=p;
}
tail->next=NULL;
return head;
}
node *DeleteList(node *head,int m)  //删除相同元素
{
node *p=head;
node *q=p->next;
while(q!=NULL)
{
if(q->d==m)
{
p->next=q->next;
delete q;
n--;
}
else
p=p->next;
q=p->next;

}
return head;
}

void PrintList(node *head)
{
node *p=head->next;
while(p!=NULL)
{
if(p->next==NULL)
cout<<p->d<<endl;
else
cout<<p->d<<" ";
p=p->next;
}
}
int main()
{
cin>>n;
node *head=NULL;
head=CreatList(n);
int m;
cin>>m;
cout<<n<<endl;
PrintList(head);
head=DeleteList(head,m);
cout<<n<<endl;
PrintList(head);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: