您的位置:首页 > 其它

HDU1390 ZOJ1383 Binary Numbers【水题+输入输出】

2016-07-26 23:50 363 查看

Binary Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6094    Accepted Submission(s): 3704


[align=left]Problem Description[/align]
Given a positive integer n, find the positions of all 1's in its binary representation. The position of the least significant bit is 0.

Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.

Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.

 

[align=left]Input[/align]
The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.

 

[align=left]Output[/align]
The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.

 

[align=left]Sample Input[/align]

1
13

 

[align=left]Sample Output[/align]

0 2 3

 

[align=left]Source[/align]
Central Europe 2001, Practice

问题链接HDU1390 ZOJ1383 Binary Numbers

问题简述:参加上文。

问题分析

  对输入的整数的各个二进制位进行判断,如果为1则输出其所在的位(从右边开始分别是0,1,2,3,...位),结果是一个集合,从小到大输出集合的各个元素。

程序说明

  这里给出两个程序,一个是计算出结果放入数组中再行输出,另外一个是一边计算一边输出。

AC的C语言程序(正解)如下:

/* HDU1390 ZOJ1383 Binary Numbers */

#include <stdio.h>

int main(void)
{
int t, n, element, ecount;

scanf("%d", &t);
while(t--) {
scanf("%d", &n);

// 计算集合并且输出结果
ecount = 0;
element = 0;
while(n) {
if(n & 1) {
ecount++;
if(ecount == 1)
printf("%d", element);
else
printf(" %d", element);
}
element++;

n >>= 1;
}
putchar('\n');
}

return 0;
}


另外一个AC的C语言程序如下:

/* HDU1390 Binary Numbers */

#include <stdio.h>

int main(void)
{
int t, n, ans[64], count, element, i;

scanf("%d", &t);
while(t--) {
scanf("%d", &n);

// 计算集合
count = 0;
element = 0;
while(n) {
if(n & 1)
ans[count++] = element;
element++;

n >>= 1;
}

// 输出结果
for(i=0; i<count; i++) {
if(i != 0)
putchar(' ');
printf("%d", ans[i]);
}
putchar('\n');
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: