您的位置:首页 > 理论基础 > 数据结构算法

暑假集训第1天链表-数据结构实验之链表五:单链表的拆分

2016-07-26 23:44 656 查看
数据结构实验之链表五:单链表的拆分

Time Limit: 1000MS Memory limit: 65536K

题目描述

输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。

输入

第一行输入整数N;;

第二行依次输入N个整数。

输出

第一行分别输出偶数链表与奇数链表的元素个数;

第二行依次输出偶数子链表的所有数据;

第三行依次输出奇数子链表的所有数据。

示例输入

10
1 3 22 8 15 999 9 44 6 1001


示例输出

4 6
22 8 44 6
1 3 15 999 9 1001

#include <stdio.h>
#include <malloc.h>
struct node
{
int data;
struct node *next;
};
void prin(struct node *head);

int main()
{
int n,i;
struct node *head,*tail,*p,*q;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
scanf("%d",&n);
for(i=0; i<n; i++)
{
p=(struct node *)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=NULL;
tail->next=p;
tail=p;
}

int k=0;
struct node *head1,*tail1;
struct node *p1;
head1=(struct node *)malloc(sizeof(struct node));
head1->next=NULL;
tail1=head1;

p=head;
q=p->next;
while(q)
{
if(q->data%2==0)
{
k++;
p1=(struct node *)malloc(sizeof(struct node));
p1->data=q->data;
p1->next=NULL;
tail1->next=p1;
tail1=p1;

p->next=q->next;
free(q);
q=p->next;
}
else
{

q=q->next;
p=p->next;
}
}

printf("%d %d\n",k,n-k);
prin(head1);
prin(head);
}
void prin(struct node *head)
{
struct node *p;
p=head->next;
while(p)
{
if(p->next)
printf("%d ",p->data);
else
printf("%d\n",p->data);
p=p->next;
}
}

[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息