您的位置:首页 > 其它

poj 2993 Emag eht htiw Em Pleh

2016-07-26 23:03 288 查看
题目链接:点击打开链接

Description
This problem is a reverse case of the
problem 2996. You are given the output of the problem H and your task is to find the corresponding
input.
Input
according to output of
problem 2996.

Output
according to input of
problem 2996.

Sample Input
White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

Sample Output
+---+---+---+---+---+---+---+---+

|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|

+---+---+---+---+---+---+---+---+

|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|

+---+---+---+---+---+---+---+---+

|...|:::|.n.|:::|...|:::|...|:p:|

+---+---+---+---+---+---+---+---+

|:::|...|:::|...|:::|...|:::|...|

+---+---+---+---+---+---+---+---+

|...|:::|...|:::|.P.|:::|...|:::|

+---+---+---+---+---+---+---+---+

|:P:|...|:::|...|:::|...|:::|...|

+---+---+---+---+---+---+---+---+

|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|

+---+---+---+---+---+---+---+---+

|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|

+---+---+---+---+---+---+---+---+
基本思路:固定的棋盘,将给出的位置填在数组中,在根据图的规律写入数组中,模拟
<span style="font-size:18px;">#include <iostream>
#include<cstring>
#include<cstdio>

using namespace std;
char mp[1000][1000];
char hk[]="+---+---+---+---+---+---+---+---+";
int main()
{
char str1[10],str2[10];
char w[1000],b[1000];
cin>>str1>>w;
cin>>str2>>b;
int lenw=strlen(w);
int lenb=strlen(b);
memset(mp,'0',sizeof(mp));
for(int i=0; ;i++)
{
if(i==lenw)
{
if(i-3<0||w[i-3]==',')
mp[2*(w[i-1]-'0')][(w[i-2]-'a')*4+2]='P';
else mp[2*(w[i-1]-'0')][(w[i-2]-'a')*4+2]=w[i-3];
break;
}
if(w[i]==',')
{
if(i-3<0||w[i-3]==',')
mp[2*(w[i-1]-'0')][(w[i-2]-'a')*4+2]='P';
else mp[2*(w[i-1]-'0')][(w[i-2]-'a')*4+2]=w[i-3];
}
}
for(int i=0; ;i++)
{
if(i==lenb)
{
if(i-3<0||b[i-3]==',')
mp[2*(b[i-1]-'0')][(b[i-2]-'a')*4+2]='p';
else mp[2*(b[i-1]-'0')][(b[i-2]-'a')*4+2]=b[i-3]+32;
break;
}
if(b[i]==',')
{
if(i-3<0||b[i-3]==',')
mp[2*(b[i-1]-'0')][(b[i-2]-'a')*4+2]='p';
else mp[2*(b[i-1]-'0')][(b[i-2]-'a')*4+2]=b[i-3]+32;
}
}

for(int i=1;i<=17;i=i+2)
{
strcpy(mp[i],hk);
}
int len=strlen(hk);
bool f=false;
for(int i=2;i<=16;i=i+2)
{
for(int j=0;j<len;j++)
{
if(mp[i][j]=='0')
{
if(j%4==0)
{
mp[i][j]='|';
f=!f;
}
else if(f==true)
{
mp[i][j]=':';
}
else if(f==false)
{
mp[i][j]='.';
}
}
}
}
for(int i=17;i>=1;i--)
{
for(int j=0;j<len;j++)
{
printf("%c",mp[i][j]);
}
printf("\n");
}
return 0;
}
</span>

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: