您的位置:首页 > 大数据 > 人工智能

2016 Multi-University Training Contest 3 Rower Bo

2016-07-26 21:46 543 查看

Rower Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)Special Judge
[align=left]Problem Description[/align]There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1,and the speed of the water flow is v2.He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks). [align=left]Input[/align]There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2.

0≤a≤100, 0≤v1,v2,≤100, a,v1,v2 are integers 
[align=left]Output[/align]For each test case,print a string or a real number.
If the absolute error between your answer and the standard answer is no more than 10−4, your solution will be accepted. [align=left]Sample Input[/align]
2 3 3
2 4 3
[align=left]Sample Output[/align]
Infinity
1.1428571429
​​
代码:#include<stdio.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<algorithm>
using namespace std;
#define INF 10000001
int main()
{
int i,j,a,v1,v2;
// freopen("1010.in.txt","r",stdin);
// freopen("1010.out.txt", "w", stdout);

while(~scanf("%d%d%d",&a,&v1,&v2))
{
if(a==0)
printf("0.0000000000\n");
else if(v1<=v2)
printf("Infinity\n");
else
printf("%.10f\n",a*v1*1.0/(v1*v1-v2*v2));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: