您的位置:首页 > 其它

HDU 5761 Rower Bo

2016-07-26 20:28 381 查看

Rower Bo

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 502 Accepted Submission(s): 146
Special Judge


[align=left]Problem Description[/align]
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1,and the speed of the water flow is v2.He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can't arrive origin anyway,print"Infinity"(without quotation marks).

[align=left]Input[/align]
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2.

0≤a≤100, 0≤v1,v2,≤100, a,v1,v2 are integers

[align=left]Output[/align]
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than 10−4, your solution will be accepted.

[align=left]Sample Input[/align]

2 3 3
2 4 3

[align=left]Sample Output[/align]

Infinity
1.1428571429

/* ***********************************************
Author        :guanjun
Created Time  :2016/7/26 15:54:55
File Name     :p310.cpp
************************************************ */
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <stdio.h>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <iomanip>
#include <list>
#include <deque>
#include <stack>
#define ull unsigned long long
#define ll long long
#define mod 90001
#define INF 0x3f3f3f3f
#define maxn 10010
#define cle(a) memset(a,0,sizeof(a))
#define pi 3.1415926
const ull inf = 1LL << 61;
const double eps=1e-5;
using namespace std;
priority_queue<int,vector<int>,greater<int> >pq;
struct Node{
int x,y;
};
struct cmp{
bool operator()(Node a,Node b){
if(a.x==b.x) return a.y> b.y;
return a.x>b.x;
}
};

bool cmp(int a,int b){
return a>b;
}

int main()
{
#ifndef ONLINE_JUDGE
freopen("in.txt","r",stdin);
#endif
//freopen("out.txt","w",stdout);
double a,v1,v2;
while(cin>>a>>v1>>v2){
if(a==0){
printf("%.7f\n",0);continue;
}
if(v1<=v2){
puts("Infinity");
}
else{
printf("%.7f\n",a*v1/(v1*v1-v2*v2));
}
}
return 0;
}


解析:





哎 。。。只要设出来r 就是v1方向上的距离就行了。。

也可以参考 http://wenku.baidu.com/view/cbce4ddebe23482fb4da4c9f?fr=prin
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: