您的位置:首页 > 其它

POJ1789 Truck History Prim+堆(优先队列)、Kruskal(并查集)

2016-07-26 20:06 330 查看
Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase
letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types
were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that
the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output
The highest possible quality is 1/3.

Source
CTU Open 2003

题意就是给你n个不同的字符串,不同的字母个数表示他们之间的距离,问这些字符串最小距离之和是多少?
好吧,扯了半天就是最小生成树。
Prim:

#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long LL;

struct Edge{
int v;
int w;
Edge(int vv=0,int ww=INF):v(vv),w(ww){}
bool operator <(const Edge & e)const
{
return w>e.w;
}
};
vector< vector<Edge> > G(2005);

int HeapPrim(const vector< vector<Edge> > &G,int N)
{
int i,j,k;
Edge xDist(0,0);
priority_queue<Edge> pq;
vector<int> vDist(N);
vector<int> vUsed(N);
for(i=0;i<N;i++){
vUsed[i]=0;
vDist[i]=INF;
}
int nDoneNum=0;
int nTotalw=0;
pq.push(Edge(0,0));
while(nDoneNum<N&&!pq.empty()){
do{
xDist=pq.top();
pq.pop();
}while(vUsed[xDist.v]&&!pq.empty());
if(!vUsed[xDist.v]){
nTotalw+=xDist.w;
vUsed[xDist.v]=1;
nDoneNum++;
for(i=0;i<G[xDist.v].size();i++){
int k=G[xDist.v][i].v;
if(!vUsed[k]){
int w=G[xDist.v][i].w;
if(vDist[k]>w){
vDist[k]=w;
pq.push(Edge(k,w));
}
}
}
}
}
if(nDoneNum<N) return -1;
return nTotalw;
}

void add(char *a,char *b,int i,int j)
{
int w=0;
for(int t=0;t<7;t++){
if(a[t]!=b[t]){
w++;
}
}
G[i].push_back(Edge(j,w));
G[j].push_back(Edge(i,w));
}

int main()
{
int N;
char a[2002][10];
while(~scanf("%d",&N),N){
for(int i=0;i<N;i++){
G[i].clear();
}
for(int i=0;i<N;i++){
getchar();
scanf("%s",a[i]);
}

for(int i=1;i<N;i++){
for(int j=0;j<i;j++){
add(a[i],a[j],i,j);
}
}
int ans=HeapPrim(G,N);
if(ans==1){
printf("The highest possible quality is 1.\n");
}else{
printf("The highest possible quality is 1/%d.\n",ans);
}
}
return 0;
}
Kruskal:(这题该算法只能勉强过,因为是密集图)
#include <iostream>
#include <cstdio>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <string>
using namespace std;
#define INF 0x3f3f3f3f
typedef long long LL;

struct Edge{
int s,e,w;
Edge(int ss,int ee,int ww):s(ss),e(ee),w(ww){}
Edge(){}
bool operator <(const Edge & e)const{
return w<e.w;
}
};
vector<Edge> edges;
vector<int> parent;
int GetRoot(int a)
{
if(parent[a]!=a){
parent[a]=GetRoot(parent[a]);
}
return parent[a];
}

void Merge(int a,int b)
{
int p=GetRoot(a);
int q=GetRoot(b);
if(p==q){
return;
}
parent[q]=p;
}
void add(char *a,char *b,int i,int j)
{
int w=0;
for(int t=0;t<7;t++){
if(a[t]!=b[t]){
w++;
}
}
edges.push_back(Edge(i,j,w));
edges.push_back(Edge(j,i,w));
}
int main()
{
int N;
char a[2002][10];
while(~scanf("%d",&N),N){
parent.clear();
edges.clear();
for(int i=0;i<N;i++){
getchar();
scanf("%s",a[i]);
}
for(int i=1;i<N;i++){
for(int j=0;j<i;j++){
add(a[i],a[j],i,j);
}
}
for(int i=0;i<N;i++){
parent.push_back(i);
}
sort(edges.begin(),edges.end());
int nDone=0;
int totalsum=0;
for(int i=0;i<edges.size();i++){
if(GetRoot(edges[i].s)!=GetRoot(edges[i].e)){
Merge(edges[i].s,edges[i].e);
nDone++;
totalsum+=edges[i].w;
}
if(nDone==N-1) break;
}
if(totalsum==1){
printf("The highest possible quality is 1.\n");
}else{
printf("The highest possible quality is 1/%d.\n",totalsum);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: