您的位置:首页 > 其它

Pick-up sticks(判断线段是否相交)

2016-07-26 11:30 429 查看
http://poj.org/problem?id=2653

Pick-up sticks

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 12394Accepted: 4673
Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan
has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.

Input
Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints
of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.

Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.

The picture to the right below illustrates the first case from input.


Sample Input
5
1 1 4 2
2 3 3 1
1 -2.0 8 4
1 4 8 2
3 3 6 -2.0
3
0 0 1 1
1 0 2 1
2 0 3 1
0

Sample Output
Top sticks: 2, 4, 5.
Top sticks: 1, 2, 3.

Hint
Huge input,scanf is recommended.

题意就是按顺序输出在最上面的线(也就是它们的上面没有线压着它们的那些线)

唯一要注意的就是两个for循环里要用break,把后面不用判断的线都排除掉,不然会超时,其他就是套模板而已。。

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <queue>
using namespace std;
int const MAXN = 100005;
struct point{
double x, y;
point(double x = 0, double y = 0);
};
typedef point Vector;
point::point(double x, double y){
this->x = x;    this->y = y;
}
struct stick{
point a, b;
}s[MAXN];
Vector operator -(const Vector &A, const Vector &B){//向量的减
return Vector(A.x - B.x, A.y - B.y);
}
double cross(point A, point B){
return A.x * B.y - A.y * B.x;
}
bool judge(point a1, point a2, point b1, point b2){
double c1 = cross(a2 - a1, b1 - a1), c2 = cross(a2 - a1, b2 - a1),
c3 = cross(b2 - b1, a1 - b1), c4 = cross(b2 - b1, a2 - b1);
return c1 * c2 < 0 && c3 * c4 < 0;
}
int main()
{
int n;
while(scanf("%d", &n) && n != 0){
for(int i = 1; i <= n; i++)
scanf("%lf %lf %lf %lf", &s[i].a.x, &s[i].a.y, &s[i].b.x, &s[i].b.y);
queue<int> q;
for(int i = 1; i <= n; i++){
for(int j = i + 1; j <= n; j++){
if(judge(s[i].a, s[i].b, s[j].a, s[j].b))
break;
if(j == n)  q.push(i);

}
}
q.push(n);
printf("Top sticks:");
while(!q.empty()){
int k = q.front();
q.pop();
printf(" %d", k);
if(q.empty())
printf(".\n");
else
printf(",");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: