您的位置:首页 > 运维架构

HDU 1500 Chopsticks(DP)

2016-07-26 11:29 295 查看
Chopsticks

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2002 Accepted Submission(s): 944

Problem Description

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length
of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)^2 is called the 'badness' of the
set.

It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father,
mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.

Input

The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers
Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).

Output

For each test case in the input, print a line containing the minimal total badness of all the sets.

Sample Input

1

1 40

1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

Sample Output

23

Note

For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160

题意:有k+8个人,n根筷子,每个人分配三根(N>=3K+24),三根筷子的长度为A、B、C(A<=B<=C),求出一种分配方式使得所有人的(A-B)^2之和最小,输出最小值。

思路:首先要将筷子的长度从大到小排序,设dp[i][j]表示前i个人在前j根中选择能得到的最小值。这样当我们考虑第一个人的时候,让他在2-N根中选择两根AB,这样就能保证至少一根筷子能比AB都长使他能成为C。同理,第二人就在5-N根中选择。

如果选择第j根和第j-1根筷子,能保证差值最小,此时dp[i][j]=min(dp[i][j],dp[i-1][j-2]+(a[j]-a[j-1])*(a[j]-a[j-1]));

如果不选第j根筷子,此时dp[i][j]=min(dp[i][j],dp[i][j-1]);

#include <stdio.h>
#include <stdlib.h>
#include <math.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <string>
using namespace std;

int dp[1050][5005];
int a[5005];

int main()
{
int t;
cin>>t;
while(t--)
{
int k,n;
scanf("%d%d",&k,&n);
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
reverse(a+1,a+n+1);
k=k+8;
memset(dp,0x3f3f3f3f,sizeof(dp));
for(int i=0;i<=n;i++)
{
dp[0][i]=0;
}
for(int i=1;i<=k;i++)
{
for(int j=3*i;j<=n;j++)
{
dp[i][j]=min(dp[i][j],dp[i-1][j-2]+(a[j-1]-a[j])*(a[j-1]-a[j]));
dp[i][j]=min(dp[i][j-1],dp[i][j]);
}
}
cout<<dp[k]
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: