您的位置:首页 > 其它

E - V

2016-07-26 08:54 323 查看
E - V
Time Limit:3000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit

Status
Description
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may
cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet,
or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay
at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then
followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.

Output
Just output one line for one test case, as described in the Description.

Sample Input
2
2
1 5
2 4
2
1 5
6 6

Sample Output
11
12

题意:一条路上有许多石头,你遇见奇数的石头时仍他,偶数时不扔,每个石头重量不同,当两块石头在同一个位置时,你会先遇见大石头(距离小的),问你遇见最后一块石头的位置.(可以重复扔石头)
思路:分类讨论:从位置0开始,如果遇到的是奇数,扔,在后面还会遇见,应该用数据结构存储起来;偶数,直接pass,因不会在后面再遇见。分析可知,优先队列存储数据。
失误:石头奇偶判断从遇见的总数中判断。
代码如下:

#include<iostream>

#include<cstdio>

#include<cstring>

#include<queue>

#include<cmath>

using namespace std;

struct node{
long long  pi;
long long  di;
friend bool operator <(node n1,node n2)
{
if(n1.pi!=n2.pi)
return n1.pi>n2.pi;
else
return n1.di>n2.di;
}

};

int main()

{
 
long long sdi,t,i,n,d,p,ord;//防止溢出 
cin>>t;
priority_queue<node> que;
node tem;

while(t--)
{
cin>>n;
for(i=1;i<=n;++i)
{
cin>>p>>d;
tem.pi=p;
tem.di=d;
que.push(tem);
}

ord=0;
while(!que.empty()) //分类讨论 
{
++ord;
tem=que.top();
que.pop();
   sdi=tem.pi;

if(ord&1)
{
tem.pi=tem.di+tem.pi;
que.push(tem);
}
}

cout<<sdi<<endl;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: