您的位置:首页 > 其它

POJ 2484 A Funny Game(博弈论)

2016-07-26 00:43 489 查看
题目链接: 传送门

A Funny Game

Time Limit: 1000MS     Memory Limit: 10000K

Description


Alice and Bob decide to play a funny game. At the beginning of the game they pick n(1 <= n <= 106) coins in a circle, as Figure 1 shows. A move consists in removing one or two adjacent coins, leaving all other coins untouched. At least one coin must be removed. Players alternate moves with Alice starting. The player that removes the last coin wins. (The last player to move wins. If you can't move, you lose.)

Note: For n > 3, we use c1, c2, ..., cn to denote the coins clockwise and if Alice remove c2, then c1 and c3 are NOT adjacent! (Because there is an empty place between c1 and c3.)

Suppose that both Alice and Bob do their best in the game.

You are to write a program to determine who will finally win the game.


Input


There are several test cases. Each test case has only one line, which contains a positive integer n (1 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.


Output


For each test case, if Alice win the game,output "Alice", otherwise output "Bob".


Sample Input

1
2
3
0

Sample Output

Alice
Alice
Bob

解题思路


这类问题,其实可以根据对称性来接,Alice先手,所以Bob可以根据链的奇偶性取走一枚或两枚硬币,然后分成两个长度相同的链,每次取走硬币与Alice相同,最后必然是Bob最后取走。


#include<cstdio>

int main()
{
int N;
while (~scanf("%d",&N) && N)
{
if (N <= 2)
{
printf("Alice\n");
}
else
{
printf("Bob\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: