您的位置:首页 > 大数据 > 人工智能

【HDU 杭电 1702】ACboy needs your help again!

2016-07-25 23:10 537 查看
ACboy needs your help again!

Problem Description

ACboy was kidnapped!!

he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor :(.

As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :” I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy.”

The problems of the monster is shown on the wall:

Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).

and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).

and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!

Input

The input contains multiple test cases.

The first line has one integer,represent the number oftest cases.

And the input of each subproblem are described above.

Output

For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.

题意:

FIFO 先进先出 队列

FILO 先进后出 栈

IN 进栈或队列

OUT 输出

一道基础的栈和队列题~~~

Sample Input

4

4 FIFO

IN 1

IN 2

OUT

OUT

4 FILO

IN 1

IN 2

OUT

OUT

5 FIFO

IN 1

IN 2

OUT

OUT

OUT

5 FILO

IN 1

IN 2

OUT

IN 3

OUT

Sample Output

1

2

2

1

1

2

None

2

3

#include<cstdio>
#include<stack>
#include<queue>
#include<cstring>
using namespace std;
void que(int n)
{
int x;
char s1[4];
queue <int> q;
while(n--)
{
scanf("%s",s1);
if(strcmp(s1,"IN")==0)
{
scanf("%d",&x);
q.push(x);
}
else if(strcmp(s1,"OUT")==0)
{
if(q.empty())
printf("None\n");
else
{
printf("%d\n",q.front());
q.pop();
}
}
}
}
void sta(int n)
{
int x;
char s1[4];
stack <int> s;
while(n--)
{
scanf("%s",s1);
if(strcmp(s1,"IN")==0)
{
scanf("%d",&x);
s.push(x);
}
else if(strcmp(s1,"OUT")==0)
{
if(s.empty())
printf("None\n");
else
{
printf("%d\n",s.top());
s.pop();
}
}
}
}
int main()
{
int t,m;
char s[6];
while(scanf("%d",&t)!=EOF)
{
while(t--)
{
scanf("%d%s",&m,s);
if(strcmp(s,"FIFO")==0)
que(m);
else if(strcmp(s,"FILO")==0)
sta(m);
else
printf("error\n");

}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电