您的位置:首页 > 其它

(模板题)poj 2190 Power of Cryptography(二分查找)

2016-07-25 21:19 1041 查看
Power of Cryptography

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 22932 Accepted: 11572
Description

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered
to be only of theoretical interest. 

This problem involves the efficient computation of integer roots of numbers. 

Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is
what your program must find).
Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10101 and there exists an integer k, 1<=k<=109 such that kn = p.
Output

For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
Sample Input
2 16
3 27
7 4357186184021382204544

Sample Output
4
3
1234

Source

México and Central America 2004


提示

题意:
密码学中目前的工作涉及(其中包括)大质数的和这些素数的数字计算能力。在这方面的工作得出的结果来自数学理论和其他分支数学曾经被认为是唯一的理论兴趣。
这个问题涉及到整数根的有效计算。给定两个整数n>=1,p=>1,你要写一个程序来计算出n的根,即求k。在这个问题上,给出了这样N和P的关系,P是永远K的N次方。
思路:
高精度+二分,二分范围就是1到p之间,没有什么需要过多讲解的。(据说double可以过,不过要用%f去输出,太傲娇了吧)


示例程序

用double做的:
Source Code

Problem: 2109		Code Length: 170B
Memory: 432K		Time: 0MS
Language: GCC		Result: Accepted
#include <stdio.h>
#include <math.h>
int main()
{
double n,p;
while(scanf("%lf %lf",&n,&p)!=EOF)
{
printf("%.0f\n",pow(p,1/n));
}
return 0;
}


常规方式:
Source Code

Problem: 2109		Code Length: 914B
Memory: 3376K		Time: 313MS
Language: Java		Result: Accepted
import java.math.*;
import java.util.*;
public class Main
{
public static void main(String[] args)
{
Scanner in = new Scanner(System.in);
int n;
BigInteger p,l,m,v,i,r;
v=BigInteger.valueOf(2);
i=BigInteger.valueOf(1);
while (in.hasNext())
{
n=in.nextInt();
p=in.nextBigInteger();
r=p;
l=BigInteger.valueOf(1);
m=l.add(r).divide(v);
while (l.compareTo(r)<=0)
{
if(m.pow(n).compareTo(p)==0)
{
break;
}
else if(m.pow(n).compareTo(p)==-1)
{
l=m.add(i);
}
else
{
r=m.subtract(i);
}
m=l.add(r).divide(v);
}
System.out.println(m);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: