您的位置:首页 > 其它

Anagram(全排列)

2016-07-25 21:04 323 查看
[align=center]Anagram[/align]

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 20171 Accepted: 8033
Description
You are to write a program that has to generate all possible words from a given set of letters.

Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".

In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input
The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase
letters are to be considered different. The length of each word is less than 13.
Output
For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order.
An upper case letter goes before the corresponding lower case letter.
Sample Input
3
aAb
abc
acba

Sample Output
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint
An upper case letter goes before the corresponding lower case letter.

So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.
Source
Southwestern European Regional Contest 1995

#include <iostream>
#include <cstdio>
#include <vector>
#include <map>
#include <set>
#include <string>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <utility>
#include <algorithm>

using namespace std;

struct rule
{
bool operator()(const char &a, const char &b)
{
if (toupper(a) != toupper(b))
{
return toupper(a) < toupper(b);
}
else
{
return a < b;
}
}
};

int main()
{
string s;
int n;
scanf("%d", &n);
while (n--)
{
cin >> s;
sort (s.begin(), s.end(), rule());
do
{
cout << s << endl;
}
while (next_permutation(s.begin(), s.end(), rule())); // 一定要记住要加排序规则, 在这里真是死了好久好久的说啊~~
}
return 0;
}

//再也别相信样例了,那个样例真是极坑基坑的说啊~~无论怎么搞都是对的,但是一直WA有个卵用啊~~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: