您的位置:首页 > 其它

【HDU】3253 - The kth great number(STL,队列)

2016-07-25 19:56 369 查看
点击打开题目


The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 9917    Accepted Submission(s): 3947


Problem Description

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help
Xiao Bao.

 

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao
Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 

 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

 

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

 

Sample Output

1
2
3

HintXiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).

 

Source

The 36th ACM/ICPC
Asia Regional Dalian Site —— Online Contest

 

用vector存数,我这里按递增顺序来存,这样就可以直接用upper_bound ( ) 函数插入数据了。

(最下面还有一种简单的方法)

代码如下:

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;
int main()
{
int n,k;
char op[4];
int num;
int pos;
while (~scanf ("%d %d",&n,&k))
{
vector<int> q;
for (int i = 1 ; i <= n ; i++)
{
scanf ("%s",op);
if (op[0] == 'I')
{
scanf ("%d",&num);
if (q.empty())
{
q.push_back(num);
continue;
}
pos = upper_bound(q.begin() , q.end() , num) - q.begin();
q.insert(q.begin() + pos , num);
}
else
{
pos = q.end() - k - q.begin();
printf ("%d\n",q[pos]);
}
}
}
return 0;
}

被虐了。智商高的人都不用管什么是 vector。

下面提供了另外一种做法, 只保留 k 个数,从小到大排,最顶的数就是需要的数。

代码如下:

#include <cstdio>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;
struct node
{
int v;
bool friend operator < (node a,node b)
{
return a.v > b.v;
}
}a;
int main()
{
int n,k;
char op[4];
while (~scanf ("%d %d",&n,&k))
{
priority_queue<node> q;
for (int i = 1 ; i <= n ; i++)
{
scanf ("%s",op);
if (op[0] == 'I')
{
int t;
scanf ("%d",&t);
if (q.size() == k)
{
a = q.top();
if (t > a.v)
{
q.pop();
a.v = t;
q.push(a);
}
}
else
{
a.v = t;
q.push(a);
}
}
else
printf ("%d\n",q.top());
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: