您的位置:首页 > 其它

POJ 2082 Terrible Sets 51nod 1102 面积最大的矩形 《题意好难懂---<贪心+单调栈>》

2016-07-25 17:55 417 查看
Terrible Sets

Time Limit: 1000MS Memory Limit: 30000KB 64bit IO Format: %lld & %llu
Submit Status

Description

Let N be the set of all natural numbers {0 , 1 , 2 , . . . }, and R be the set of all real numbers. wi, hi for i = 1 . . . n are some elements in N, and w0 = 0. 

Define set B = {< x, y > | x, y ∈ R and there exists an index i > 0 such that 0 <= y <= hi ,∑ 0<=j<=i-1wj <= x <= ∑ 0<=j<=iwj} 

Again, define set S = {A| A = WH for some W , H ∈ R + and there exists x0, y0 in N such that the set T = { < x , y > | x, y ∈ R and x0 <= x <= x0 +W and y0 <= y <= y0 + H} is contained in set B}. 

Your mission now. What is Max(S)? 

Wow, it looks like a terrible problem. Problems that appear to be terrible are sometimes actually easy. 

But for this one, believe me, it's difficult.

Input

The input consists of several test cases. For each case, n is given in a single line, and then followed by n lines, each containing wi and hi separated by a single space. The last line of the input is an
single integer -1, indicating the end of input. You may assume that 1 <= n <= 50000 and w 1h 1+w 2h 2+...+w nh n < 10 9.

Output

Simply output Max(S) in a single line for each case.

Sample Input

3
1 2
3 4
1 2
3
3 4
1 2
3 4
-1


Sample Output

12
14


Source

Shanghai 2004 Preliminary

题意不好理解--题意理解了就简单多了-.-

n个矩形连在一起-问我们可以截的最大的矩形面积是多少-.-

附上学长的图文结合的样例分析--点击打开链接

代码:

#include<cstdio>
#include<stack>
#include<cstring>
#include<algorithm>
using namespace std;
struct node {
int w,h;
}chu;
int main()
{
int n;
while (scanf("%d",&n),n!=-1)
{
int ws,hs,ww,hh,ss=0;
stack<node > sta;
chu.h=0;chu.w=0;
sta.push(chu);
while (n--)
{
scanf("%d%d",&ww,&hh);
if (hh>sta.top().h)
{
chu.h=hh;chu.w=ww;
sta.push(chu);
}
else
{
ws=0;
while (hh<=sta.top().h)
{
chu=sta.top();
sta.pop();
ws+=chu.w;
ss=max(ss,ws*chu.h);
}
ww+=ws;
chu.h=hh;chu.w=ww;
sta.push(chu);
}
}
ws=0;
while (!sta.empty())
{
chu=sta.top();
sta.pop();
ws+=chu.w;
ss=max(ss,ws*chu.h);
}
printf("%d\n",ss);
}
return 0;
}


51nod 1102 面积最大的矩形链接:点击打开链接

代码和上面的差不多-.-稍微改一些-.-把输入ww--直接改成ww=1;并用longlong就行了-.-

代码:

#include<cstdio>
#include<stack>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long
struct node {
LL w,h;
}chu;
int main()
{
int n;
scanf("%d",&n);
LL ws,hs,ww,hh,ss=0;
stack<node > sta;
chu.h=0;chu.w=0;
sta.push(chu);
while (n--)
{
scanf("%lld",&hh);
ww=1;
if (hh>sta.top().h)
{
chu.h=hh;chu.w=ww;
sta.push(chu);
}
else
{
ws=0;
while (hh<=sta.top().h)
{
chu=sta.top();
sta.pop();
ws+=chu.w;
ss=max(ss,ws*chu.h);
}
ww+=ws;
chu.h=hh;chu.w=ww;
sta.push(chu);
}
}
ws=0;
while (!sta.empty())
{
chu=sta.top();
sta.pop();
ws+=chu.w;
ss=max(ss,ws*chu.h);
}
printf("%lld\n",ss);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: