您的位置:首页 > 其它

POJ 1979 Red and Black(DFS)

2016-07-25 17:05 369 查看
Red and Black

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 

'#' - a red tile 

'@' - a man on a black tile(appears exactly once in a data set) 

The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output
45
59
6
13

题目大意:一个房间里面铺满了红色(用#表示)和黑色(用.表示)的地板,有一个人在房间里走动,他只能走在黑色地板上,不能走在红色地板上,这个人一开始站在某一块黑色地板上,求他能走过的黑色地板的数目。
解题思路:DFS求连通块,要算上最开始的那一块地板,注意输入的行和列是反着的。

代码如下:

#include <cstdio>
#include <algorithm>
#include <cstring>

using namespace std;

const int maxw = 25;
const int maxh = 25;

char room[maxh][maxw];
int dir[4][2] = {{0,1},{1,0},{0,-1},{-1,0}};
int w,h;
int ans;
void dfs(int x,int y)
{
room[x][y] = '#';
ans++;
for(int i = 0;i < 4;i++){
int nx = x + dir[i][0];
int ny = y + dir[i][1];
if(0 <= nx && nx < h && 0 <= ny && ny < w && room[nx][ny] != '#'){
dfs(nx,ny);
}
}
return ;
}

int main()
{
while(scanf("%d %d",&w,&h) != EOF && (w || h)){
ans = 0;
for(int i = 0;i < h;i++){
scanf("%s",room[i]);
}
for(int i = 0;i < h;i++){
for(int j = 0;j < w;j++){
if(room[i][j] == '@'){
dfs(i,j);
}
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ