您的位置:首页 > 其它

Power Strings --KMP

2016-07-25 16:33 405 查看
/****

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd

aaaa

ababab

.

Sample Output

1

4

3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

+

********/
#include <iostream>

#include<string.h>

#include<stdio.h>

using namespace std;

int next[10000005];

void getnext(char *S,int& R)

{

    int j=0;

    next[0]=0;

    for(int i=1; S[i]!='\0'; i++)

    {

        while(j>0&&S[i]!=S[j])

        {

            j=next[j-1];

        }

        if(S[i]==S[j])

        {

            j++;

        }

        next[i]=j;

    }

}

int main()

{

    char S[1000005];

    while(scanf("%s",S)&&S[0]!='.')

    {

        memset(next,0,sizeof(next));

        int R=0;

        getnext(S,R);

        int l=strlen(S);

        int j=next[l-1];

        int m=l-j,k=j,B;

        while(j>0)

        {

            if(j==m)

            {

                B=1;

                break;

            }

            j=next[j-1];

            int n=k-j;

            if(n!=m)

            {

                B=0;

                break;

            }

            k=j;

        }

        if(B)

            cout<<l/(m)<<endl;

        else

            cout<<"1"<<endl;

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: