您的位置:首页 > 其它

POJ 1611 (并查集)

2016-07-25 16:17 483 查看
The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 32929 Accepted: 15965
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others. 

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP). 

Once a member in a group is a suspect, all members in the group are suspects. 

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space. 

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

Source
Asia Kaohsiung 2003

题意:
有一个学校,有N个学生,编号为0到n-1,现在0号学生感染了非典,凡是和0在一个社团的人就会感染,并且这些人如果还参加了别的社团,他所在的社团照样全部感染,求感染的人数。
分析:
并查集的变形,只要和0同学有关的,间接有关的都视为可能感染; 在每个团体输入时,第一个同学不考虑,后面的每个同学与第一个同学比较,归为同一集合,最后看与father[i]==father[0]的有几个,即为所求:

代码:

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#include <iostream>
using namespace std;

#define  N 50000
int father
;
int n,m;

int Find(int x)
{
while(x!=father[x])
x=father[x];
return x;
}

void join(int a,int b)
{
int x,y;
x=Find(a);
y=Find(b);
if(x!=y)
{
if(x>y)
father[y]=x;
else
father[x]=y;
}
}

int main()
{
int i,j,k;
int a,b;
while(scanf("%d%d",&n,&m),m+n)
{
for(i=0; i<n; i++)
father[i]=i;

for(i=1; i<=m; i++)
{
scanf("%d%d",&k,&a);
for(j=1;j<k;j++)
{
scanf("%d",&b);
join(a,b);
}
}
int ans=0;
int p=Find(0);
for(i=0;i<n;i++)
if(Find(i)==p)
ans++;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: