您的位置:首页 > 其它

数数字

2016-07-25 14:25 357 查看

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N(1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

12345678910111213

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

For each test case, there is one single line containing the number N .

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space.

Sample Input 

2
3
13

Sample Output 

0 1 1 1 0 0 0 0 0 0
1 6 2 2 1 1 1 1 1 1
#include <stdio.h>
#include <string.h>
int main()
{
    int a[15];
    int t,n;
   scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));//就是将a数组全部赋值为0,填充以字节为单位
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            int t=i;          //令t等于1开始到n的各个数
            while(t)          //t次循环得到各位上的数字
            {
                int num=t%10;
                a[num]++;   //a[1]=1
                t/=10;         
            }
        }
        for(int i=0;i<10;i++)
        {  if(i)printf(" ");
            printf("%d",a[i]);
        }
       printf("\n");
    }
    return 0;
}
阅读更多
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: