您的位置:首页 > 其它

POJ3461 Oulipo KMP基础

2016-07-25 12:23 239 查看
Oulipo

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35044 Accepted: 14146
Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination,
l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program
that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T,
count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN


Sample Output
1
3
0

题意:标准题意。
注意这里每次匹配成功后的 j=p[j],如果是-1求出的数量,是互不相交的数量,这样答案就错了。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
const int maxm=1000005;
int p[maxm],n,m;char a[maxm],b[maxm];
void find();
int kmp();
int main()
{
int i,j,k,sum,t;
scanf("%d",&t);
while(t--)
{
scanf("%s",b);
scanf("%s",a);
n=strlen(a);
m=strlen(b);
find();
printf("%d\n",kmp());
}
return 0;
}
void find()
{
int i,j=-1;
p[0]=-1;
for(i=1;i<m;i++)
{
while(j>=0 && b[j+1]!=b[i])
j=p[j];
if(b[j+1]==b[i])
j++;
p[i]=j;
}
}
int kmp()
{
int i,j=-1,ans=0;
for(i=0;i<n;i++)
{
while(j>=0 && b[j+1]!=a[i])
j=p[j];
if(b[j+1]==a[i])
j+=1;
if(j==m-1)
{
j=p[j];
ans+=1;
}
}
return ans;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: