您的位置:首页 > 运维架构

Hopscotch POJ3050

2016-07-25 11:05 369 查看
Hopscotch

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 3284 Accepted: 2271

Description

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

Lines 1..5: The grid, five integers per line

Output

Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1

1 1 1 1 1

1 1 1 1 1

1 1 1 2 1

1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS:

111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

Source

USACO 2005 November Bronze

题意 :给一个5X5的数字矩阵,问你一共可以组成几种5位数

思路:暴力枚举,set判重

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<set>
#include<string>

using namespace std;

int a[10][10];
set<int>se;
int ans;
int dx[]={0,0,1,-1};
int dy[]={1,-1,0,0};
void dfs(int x,int y,int tmp,int num)
{
if(num>=5)
{
if(!se.count(tmp))
{
// printf("%d\n",tmp);
se.insert(tmp);
ans++;
}
return ;

}
for(int i=0;i<4;i++)
{
int xx,yy;
xx=x+dx[i];
yy=y+dy[i];
if(xx>=0&&xx<5&&yy>=0&&yy<5)
dfs(xx,yy,tmp*10+a[xx][yy],num+1);
}

}
int main()
{
se.clear();
for(int i=0;i<5;i++)
{
for(int j=0;j<5;j++)
{
scanf("%d",&a[i][j]);
}
}

for(int i=0;i<5;i++)
{
for(int j=0;j<5;j++)
{
dfs(i,j,a[i][j],0);
}

}
printf("%d\n",ans);
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: