您的位置:首页 > 其它

HDU 5748 Bellovin(最长上升子序列[nlogn])

2016-07-25 10:47 405 查看


Bellovin

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 627    Accepted Submission(s): 291


Problem Description

Peter has a sequence a1,a2,...,an and
he define a function on the sequence -- F(a1,a2,...,an)=(f1,f2,...,fn),
where fi is
the length of the longest increasing subsequence ending with ai.

Peter would like to find another sequence b1,b2,...,bn in
such a manner that F(a1,a2,...,an) equals
to F(b1,b2,...,bn).
Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence a1,a2,...,an is
lexicographically smaller than sequence b1,b2,...,bn,
if there is such number i from 1 to n,
that ak=bk for 1≤k<i and ai<bi.

 

Input

There are multiple test cases. The first line of input contains an integer T,
indicating the number of test cases. For each test case:

The first contains an integer n (1≤n≤100000) --
the length of the sequence. The second line contains n integers a1,a2,...,an (1≤ai≤109).

 

Output

For each test case, output n integers b1,b2,...,bn (1≤bi≤109) denoting
the lexicographically smallest sequence.

 

Sample Input

3
1
10
5
5 4 3 2 1
3
1 3 5

 

Sample Output

1
1 1 1 1 1
1 2 3

 

Source

BestCoder Round #84

 

观察下就知道F(f_1,f_2,...,f_n)=F(a_1,a_2,...,a_n)F(f​1​​,f​2​​,...,f​n​​)=F(a​1​​,a​2​​,...,a​n​​),
显然这个是字典序最小的, 于是要求的序列就是f_1,f_2,...,f_nf​1​​,f​2​​,...,f​n​​.

#include <map>
#include <cmath>
#include <vector>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;
int T, n, m;
const int INF = 0x3f3f3f3f;
const int MAXN = 1e5 + 5;
int A[MAXN], dp[MAXN];
vector<int>stacks;

void solvem() {
int top = -1;
stacks.clear();
for(int i = 0; i < n; i ++) {
if(top == -1 || stacks[top] < A[i]) stacks.push_back(A[i]), top ++;
int lb = -1, ub = top;
while(ub - lb > 1) {
int mid = (ub + lb) >> 1;
if(stacks[mid] < A[i]) lb = mid;
else ub = mid;
}
stacks[ub] = A[i];
printf("%d%c", ub + 1, i == n - 1 ? '\n':' ');
}
}

void solve() {
fill(dp, dp + n, INF);
for(int i = 0; i < n; i ++) {
int* a = lower_bound(dp, dp + n, A[i]);
*a = A[i];
printf("%d%c", a - dp + 1, i != n - 1 ? ' ': '\n');
}
}

int main() {
while(~scanf("%d", &T)) {
while(T --) {
scanf("%d", &n);
for(int i = 0; i < n; i ++) {
scanf("%d", &A[i]);
}
//solve();
solvem();
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: