您的位置:首页 > 其它

杭电ACM1002--大数相加

2016-07-25 07:55 387 查看
[align=left]Problem Description[/align]
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should
not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the
equation. Output a blank line between two test cases.

[align=left]Sample Input[/align]

2
1 2
112233445566778899 998877665544332211


[align=left]Sample Output[/align]

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

1、用java的BigInteger类来做非常简单.
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int t;
BigInteger n,m;
t=sc.nextInt();
for(int i=0 ;  i<t ; i++){
if(i>0)System.out.println();
n = new BigInteger(""+sc.nextBigInteger());
m = new BigInteger(""+sc.nextBigInteger());
System.out.println("Case "+(i+1)+":");
System.out.println(n+" + "+m+" = "+m.add(n));
}
}
}

2、用c/c++来写代码相对较长,用数组来做
[code]#include<stdio.h>
#include<string.h>
int main ()
{
int a[1002],b[1002],Case=0,t,i,l,j,p;
char x[1002],y[1002];
scanf("%d",&t);
while(t--)
{
getchar();
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%s%s",x,y);
l=strlen(x)>strlen(y)?strlen(x):strlen(y);
j=p=0;
for(i=l-1; i>=0; i--)
{
if(x[i]>='0'&&x[i]<='9')
{
a[j]=x[i]-'0';
j++;
}
if(y[i]>='0'&&y[i]<='9')
{
b[p]=y[i]-'0';
p++;
}
}
printf("Case %d:\n",++Case);
for(i=0; i<l; i++)
{
if(a[i]+b[i]>=10)
{
a[i]=(a[i]+b[i])-10;
a[i+1]++;
}
else
{
a[i]=a[i]+b[i];
}
}
printf("%s + %s = ",x,y);
if(a[l]!=0)printf("%d",a[l]);
for(i=l-1; i>=0; i--)
{
printf("%d",a[i]);
}
if(t==0)printf("\n");
else printf ("\n\n");
}
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: