您的位置:首页 > 其它

Hust oj 1052 Darts(翻译题)

2016-07-24 19:42 393 查看
Darts
Time Limit: 1000 MSMemory Limit: 65536 K
Total Submit: 50(22 users)Total Accepted: 30(20 users)Rating:







Special Judge: No
Description
Background

Many nations (including Germany) have a strange tradition of throwing small arrows at round flat targets (usually, these small arrows are called darts and so is the game).

In a darts game, the target consists of a flat circle which is divided into slices and rings. The slices are numbered from 1 to 20 and the rings are called double or treble ring (see Figure 1). The center part of the board is
called the bull’s eye which is further subdivided into an inner part (the real bull’s eye) and an outer part (called the bull, see Fig. 1).



Figure 1: Layout of a dart board

Players take turns in throwing the darts at the board. Their score depends on the areas they hit with their darts. Hitting the 20 slice in the double ring scores 2 * 20 = 40 points. Hitting the treble ring multiplies the score by 3. The inner part of the bull’s
eye counts 50, the outer part 25 points.

Every turn consists of 3 darts being thrown at the dartboard by a player and his score is the sum of the scores of all darts which hit the dartboard in one of the numbered areas.

Problem

Your friends have played darts yesterday and from their match the scores are still on the blackboard in your room. From reading the scores, you would like to know, how the individual players threw their darts and where they could
have hit the dartboard. You are to write a program which, given the score of a turn, reconstructs the number of possible distinct combinations of hits of the three darts on the dartboard ignoring the order in which the darts are thrown.

As an example, consider the overall score of 3 of a player. This could have happened as follows:

3 = 0 + 0 + 1*3 one dart hits slice 3

3 = 0 + 0 + 3*1 one dart hits slice 1 in treble ring

3 = 0 + 1*1 + 1*2 one dart hits slice 1 and one dart hits slice 2

3 = 0 + 1*1 + 2*1 one dart hits slice 1 and one dart hits slice 1 in double ring

3 = 1*1 + 1*1 + 1*1 all three darts hit slice 1

The resulting sum of possible distinct combinations is 5.

A more complex example is score 9:

9 = 0 + 0 + 1*9 one dart hits slice 9

9 = 0 + 0 + 3*3 one dart hits slice 3 in treble ring

9 = 0 + 1*1 + 1*8 one dart hits slice 1 and one dart hits slice 8

9 = 0 + 1*1 + 2*4 one dart hits slice 1 and one dart hits slice 4 in double ring

...

9 = 0 + 3*2 + 1*3 one dart hits slice 2 in treble ring and one dart hits slice 3

9 = 1*1 + 1*1 + 1*7 two darts hit slice 1 and one dart hits slice 7

...

9 = 2*1 + 3*1 + 2*2 one dart hits slice 1 in double ring, one dart hits slice 1 in treble ring and one dart hits slice 2 in double ring

9 = 1*3 + 1*3 + 1*3 three darts hit slice 3

9 = 1*3 + 1*3 + 3*1 two darts hit slice 3 and one dart hits slice 1 in treble ring

9 = 1*3 + 3*1 + 3*1 one dart hits slice 3 and two darts hit slice 1 in treble ring

9 = 3*1 + 3*1 + 3*1 three darts hit slice 1 in treble ring

What is the number of combinations? Write a program to find out.

Input
The first line contains the number of scenarios.

For each scenario, you are give a dart score as a single positive integer on a line by itself.

Output
The output for every scenario begins with a line containing “Scenario #i:” where i is the number of the scenario starting at 1. Then print the number of possible dart score combinations on a line by itself. Finish
the output of every scenario with a blank line.

Sample Input
2

3

9

Sample Output
Scenario #1:

5

Scenario #2:

41

poj上原题,一共就63种分,暴力就可以了,主要是读题看着烦= =
#include <iostream>
using namespace std;
int a[63]={0,1,2,3,4,5,6,7,8,9,
10,11,12,13,14,15,16,17,18,19,
20,2 ,4 ,6 ,8 ,10,12,14,16,18,
20,22,24,26,28,30,32,34,36,38,
40,3 ,6 ,9 ,12,15,18,21,24,27,
30,33,36,39,42,45,48,51,54,57,
60,50,25};
int solve(int score)
{
int i,j,k,res=0;
for (i=0;i<63;++i)
for (j=i;j<63;++j)
for (k=j;k<63;++k)
if(a[i]+a[j]+a[k]==score)
++res;
return res;
}
int main()
{
int cnt,score;
scanf("%d",&cnt);
for (int i=1;i<=cnt;++i)
{
scanf("%d",&score);
printf("Scenario #%d:\n%d\n\n",i,solve(score));
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hustoj1052 poj1959