您的位置:首页 > 其它

hdu 1016 Prime Ring Problem (dfs)

2016-07-24 19:38 513 查看
题意:输入一个n(n<20),输出所有的素数环(相邻两个相加等于素数)。

Note: the number of first circle should always be 1.



Sample Input

6
8

 

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int prime[41]={0,0,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,0,1,0,0,0,0,0,1,0},n;
int vis[25],a[25];
void dfs(int x)
{int i;
if(x==n&&prime[a[x-1]+a[0]]==1)
{

for(i=0;i<n-1;i++) printf("%d ",a[i]);
printf("%d\n",a[n-1]);
}
else
{
for(i=2;i<=n;i++)
{
if(!vis[i])
{
if(prime[a[x-1]+i])
{
a[x]=i;
vis[i]=1;
x++;
dfs(x);
vis[i]=0;
x--;
}
}
}
}
}
int main()
{
int cas=0;
while(~scanf("%d",&n))
{
cas++;
printf("Case %d:\n",cas);
memset(a,0,sizeof(a));
memset(vis,0,sizeof(vis));
a[0]=1;
dfs(1);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: