您的位置:首页 > 其它

poj1083贪心

2016-07-24 19:16 337 查看
Moving Tables

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 30047 Accepted: 9997
Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only
one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the
part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the
possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move. 

Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd 

line, the remaining test cases are listed in the same manner as above.
Output

The output should contain the minimum time in minutes to complete the moving, one per line.
Sample Input
3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output
10
20

30


题意就是在一条走廊旁边有两排房间,搬动椅子,椅子只能一次性在一个地方般一张

这里就是覆盖过后就行了,下面代码中注意了,是从0开始的,因此求start  和end时候需要减去一

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int a[205];

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
memset(a,0,sizeof(a));
int n;
scanf("%d",&n);
while(n--)
{
int x,y;
scanf("%d%d",&x,&y);
int start=((x<y?x:y)-1)/2;
int endn=((x>y?x:y)-1)/2;
for(int i=start;i<=endn;i++)
a[i]+=10;
}
int ans=0;
for(int i=0;i<200;i++)
ans=a[i]>ans?a[i]:ans;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: