您的位置:首页 > 其它

HDU1372 Knight Moves(BFS)

2016-07-24 14:50 441 查看

Knight Moves

Problem Description

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most
difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing
the row on the chessboard.

Output

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6


Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.


————————————————————————————————————————————

象棋的马的走法,走日子,计方向时注意点,其他和普通的没两样

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
int map[10][10];
int dir[8][2]={{-2,-1},{-1,-2},{-1,2},{-2,1},{2,1},{1,2},{2,-1},{1,-2}};

struct node
{
int x,y,cnt;

};
bool cheak(int i,int j)
{
if(i<1||i>8||j<1||j>8)
return 0;
else
return 1;

}
int bfs(int si,int sj,int di,int dj)
{
queue<node>q;
node f,d;
f.x=si;
f.y=sj;
f.cnt=0;
q.push(f);
while(!q.empty())
{
f=q.front();
q.pop();
if(f.x==di&&f.y==dj)
return f.cnt;
for(int i=0;i<8;i++)
{
d.x=f.x+dir[i][0];
d.y=f.y+dir[i][1];
if(cheak(d.x,d.y))
{
d.cnt=f.cnt+1;
q.push(d);
}
}
}
return -1;
}

int main()
{
char a,b;
int xa,xb,ya,yb;
while(~scanf("%c%d %c%d",&a,&ya,&b,&yb))
{
getchar();
xa=a-'a'+1;
xb=b-'a'+1;
int ans=bfs(xa,ya,xb,yb);
printf("To get from %c%d to %c%d takes %d knight moves.\n",a,ya,b,yb,ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: