您的位置:首页 > 其它

LightOJ 1275 Internet Service Providers <一元二次函数的最值>

2016-07-24 13:12 429 查看
Internet Service Providers

Time Limit: 2000MSMemory Limit: 32768KB64bit IO Format: %lld & %llu
Submit Status 

uDebug


Description

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through
the channel and gets a profit that is directly proportional to the factor T(C - T*N). The problem is to compute the smallest value of T that maximizes the total profit the N ISPs can get from using the channel.
Notice that N, C, T, and the optimal T are integer numbers.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a line containing two integers N and C (0 ≤ N, C ≤ 109).

Output

For each case, print the case number and the minimum possible value of T that maximizes the total profit. The result should be an integer.

Sample Input

6

1 0

0 1

4 3

2 8

3 27

25 1000000000

Sample Output

Case 1: 0

Case 2: 0

Case 3: 0

Case 4: 2

Case 5: 4

Case 6: 20000000

让一元二次函数最大

代码:

#include<cstdio>
int main()
{
int t;scanf("%d",&t);
for (int i=1;i<=t;i++)
{
int n,c;
scanf("%d%d",&n,&c);
if (n==0)
{
printf ("Case %d: 0\n",i);
continue;
}
int kp=c/(2*n);
if (((-n)*kp*kp+kp*c)<((-n)*(kp+1)*(kp+1)+(kp+1)*c))
printf ("Case %d: %d\n",i,kp+1);
else
printf("Case %d: %d\n",i,kp);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: