您的位置:首页 > 其它

POJ 3984 BFS走迷宫问题

2016-07-23 21:59 399 查看
POJ 3984 BFS走迷宫问题,题目的链接如下:

http://poj.org/problem?id=3984

A - 迷宫问题

Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%lld & %llu

Submit

Status

Description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0

0 1 0 1 0

0 0 0 0 0

0 1 1 1 0

0 0 0 1 0

Sample Output

(0, 0)

(1, 0)

(2, 0)

(2, 1)

(2, 2)

(2, 3)

(2, 4)

(3, 4)

(4, 4)

#include <iostream>//代码是找的,做一下午已经死了
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <string>
#include <algorithm>
#include <functional>
#include <set>
#include <map>
#include <queue>
#include <stack>
#include <vector>
const int N = 5 ;
using namespace std;
struct note
{
int x,y,pre;//存放坐标,前一个节点在队列中的位置
} que[100];
int map1

;
int Nx[4]= {1,-1,0,0};
int Ny[4]= {0,0,-1,1};
int start=0,end=1;//用que结构体数组模拟一个队列
void print(int s)
{
if(que[s].pre!=-1)
{
//递归输出
print(que[s].pre);//根据查找前一个的位置来递归
cout<<"("<<que[s].x<<", "<<que[s].y<<")"<<endl;
}
}
void bfsMap(int x,int y)
{
que[start].pre=-1;
que[start].x=x;
que[start].y=y;
while(start<end)
{
for(int i=0; i<4; i++)
{
int a=Nx[i]+que[start].x;
int b=Ny[i]+que[start].y;
if(a<0 || b<0 || a>=N || b>=N || map1[a][b])//如果出界或者遇到墙或者已经被访问
continue;
else
{
map1[a][b]=-1;//设置已经访问过
//入队
que[end].pre=start;
que[end].x=a;
que[end].y=b;
end++;//数组大小
}
if(a==N-1 && b==N-1)
print(start);
}
start++;
}
}
int main()
{
int i,j;
for(i=0; i<N; i++)
for(j=0; j<N; j++)
scanf("%d",&map1[i][j]);
cout<<"(0, 0)"<<endl;
bfsMap(0,0);
cout<<"("<<N-1<<", "<<N-1<<")"<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  bfs poj