您的位置:首页 > 其它

HDU 5323 Solve this interesting problem(dfs结合线段树特点剪枝)

2016-07-23 21:04 471 查看
Problem Description

Have you learned something about segment tree? If not, don’t worry, I will explain it for you.

Segment Tree is a kind of binary tree, it can be defined as this:

- For each node u in Segment Tree, u has two values: Lu and Ru.

- If Lu=Ru,
u is a leaf node. 

- If Lu≠Ru,
u has two children x and y,with Lx=Lu,Rx=⌊Lu+Ru2⌋,Ly=⌊Lu+Ru2⌋+1,Ry=Ru.

Here is an example of segment tree to do range query of sum.



Given two integers L and R, Your task is to find the minimum non-negative n satisfy that: A Segment Tree with root node's value Lroot=0 and Rroot=n contains
a node u with Lu=L and Ru=R.

 

Input

The input consists of several test cases. 

Each test case contains two integers L and R, as described above.
0≤L≤R≤109
LR−L+1≤2015

 

Output

For each test, output one line contains one integer. If there is no such n, just output -1.

 

Sample Input

6 7
10 13
10 11

 

Sample Output

7
-1
12

 

Author

ZSTU

 

Source

2015 Multi-University Training Contest 3

 
题意:
给出区间[l,r]要求找到一棵线段树,使[l,r]是线段树上的一个区间,求满足的线段树中最大区间[0,n]的n
如果有多解,取最小的解
分析:
显然需要自下而上的搜索线段树,对于区间[l,r],它可能是它爸爸的左儿子,也可能是它爸爸的右儿子
当它是左儿子,它爸爸的区间左端点为l,右端点有两种情况(因为对于式子  mid = (l+r)/2 , 同样的mid 有两个(l+r)/2满足条件)
:  rx1 = 2*r - l 或者 rx2 = 2*r +1 - l 
同理,当它是右儿子,它爸爸的区间右端点为r,左端点为: lx1 = 2*(l-1)-r 或 lx2 = 2*(l-1)+1-r
剪枝:1.当前搜索的区间右端点已经大于已知的答案则无需继续,继续下去再找到的答案也必然比已知的答案大
   2.根据 线段树左儿子不可能比右儿子表示的区间长度小 的特点,故当l<(r-l+1)时返回

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
ll ans;
void dfs(ll l,ll r)
{
if (l == 0)
{
if (ans == -1)  ans = r;
else ans = min(ans,r);
return;
}
if (l < 0) return;
if (ans != -1&&r >= ans) return;//剪枝1
//剪枝2:l<(r-l+1)无解,因为线段树左儿子不可能比右儿子表示的区间长度小
if (l < (r-l+1)) return ;
//枚举区间[l,r]上一层的区间,[l,r]可能是其爸爸的左儿子,也可能是其爸爸的右儿子
//对于式子(l+r)/2 = mid,同样的mid 有2个(l+r)/2满足条件
ll lx1 = 2*(l-1) - r;
ll lx2 = (2*(l-1))+1 - r;
ll rx1 = 2*r - l;
ll rx2 = 2*r+1 - l;
dfs(lx1,r);
dfs(lx2,r);
dfs(l,rx1);
dfs(l,rx2);
}
int main()
{
ll l,r;
while (~scanf("%I64d %I64d",&l,&r))
{
ans = -1;
dfs(l,r);
printf("%I64d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  hdu dfs