您的位置:首页 > 其它

POJ-1328 Radar Installation

2016-07-23 20:48 375 查看
Radar Installation

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 75484 Accepted: 16905

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations



Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.

Sample Input

3 2

1 2

-3 1

2 1

1 2

0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

思路:

相对原点而言,我们假定x负半周方向为“左”,x正半轴方向为“右”。

我们找一个岛屿能被侦测到的极限范围,在雷达侦测区(圆)的左半圆上或者在雷达侦测区(圆)的右半圆上,换句话说当岛屿到雷达的距离等于d时,

雷达可以位于岛屿的左侧也可以位于雷达的右侧。而这就可以分别确定雷达相对与岛屿x的最左坐标和x最右坐标。

最左为:x - sqrt(d*d-y*y); 最右为:x - sqrt(d*d-y*y);

每个岛屿都有这样的最左和最右可被侦测坐标。

根据贪婪的思想,每次都应该将最右可被侦测坐标作为衡量标准。

假定当前的岛屿为p,当前的下一个为next。

1.如果next的最左可被侦测坐标比p的最右都大的话,只能再设一个雷达来侦测next了。

2.如果next的最左可被侦测坐标比p的最右小,这时会有两种情况。

A.next最右 < cur最右

B.next最右 >= cur最右

对于B情况,我们可以直接侦测到next了, 可以找next的next了.

对于A情况,也就等价于next包含于p, 这样就应该把next的右最为衡量标准了.

因为这样可以左移最右坐标, 可以让可能更多的岛屿被侦测到(他们的最左与衡量标准有更多的交集)

提供一组测试数据:

20 8

-20 7

-18 6

-5 8

-21 8

-15 7

-17 5

-1 5

-2 3

-9 6

1 2

2 3

3 4

4 5

5 6

6 7

7 8

8 7

9 6

10 5

0 0

答案是 4.

代码如下:

#include <cstdio>
#include <algorithm>
#include<math.h>
#include<string.h>
using namespace std;
struct dao
{
double x,y,l,r;
}p[1005];
bool cmp(dao a,dao b)
{
return a.l<b.l;
}
int main()
{
int n,d,a=1;
while(~scanf("%d%d",&n,&d)&&n||d)
{
int sum=1;
for(int i=0;i<n;i++)
{
scanf("%lf%lf",&p[i].x,&p[i].y);
p[i].l=p[i].x-sqrt(fabs(d*d-p[i].y*p[i].y));
p[i].r=p[i].x+sqrt(fabs(d*d-p[i].y*p[i].y));
if(d<p[i].y) sum=0;
}
if(!sum)
{
printf("Case %d: -1\n",a++);
continue;
}
sort(p,p+n,cmp);
double z=p[0].r;
for(int i=1;i<n;i++)
{
if(z<p[i].l)
{
sum++;
z=p[i].r;
}
else
{
if(p[i].r<z) z=p[i].r;
}
}
printf("Case %d: %d\n",a++,sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: