您的位置:首页 > 其它

HDOJ—1061—Rightmost Digit

2016-07-23 20:05 323 查看

Rightmost Digit

Time Limit:1000MS     Memory Limit:32768KB     64bit
IO Format:
%I64d & %I64u
Submit Status

Description

Given a positive integer N, you should output the most right digit of N^N. 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 

Each test case contains a single positive integer N(1<=N<=1,000,000,000). 

 

Output

For each test case, you should output the rightmost digit of N^N. 

 

Sample Input

2
3
4

 

Sample Output

7
6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.

代码:
#include<cstdio>
__int64 qpow(__int64 n)
{
__int64 cnt=n,ans=1;
while(n)
{
if(n&1)
{
ans=(cnt*ans)%10;
}
cnt=cnt*cnt%10;
n>>=1;
}
return ans;
}
int main()
{
__int64 t;
scanf("%I64d",&t);
while(t--)
{
__int64 n;
scanf("%I64d",&n);
printf("%I64d\n",qpow(n));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: