您的位置:首页 > 其它

POJ 1017 Packets (贪心)

2016-07-23 17:08 603 查看
Packets

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 51513 Accepted: 17464
Description

A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because
of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels
necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.
Input

The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest
size 6*6. The end of the input file is indicated by the line containing six zeros.
Output

The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last
``null'' line of the input file.
Sample Input
0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output
2
1

Source

Central Europe 1996

题意:一个公司出售1*1,2*2,3*3,4*4,5*5,6*6的木板,但这个公司只有6*6的木板,其他类型的木板都是由6*6的分割而来。给出每种木板的需求量,问最少需要多少6*6的木板

思路:从大木板开始分割,

渣渣就是渣渣

,写代码的能力太差,自己模拟的这个过程好复杂,代码写了好长,大神的代码简单又容易理解。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int i,j,k,l,m,n,sum,a[10],b[]={0,5,3,1};
while(scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6]),a[1]+a[2]+a[3]+a[4]+a[5]+a[6])
{
int ans=0;
ans+=a[6]+a[5]+a[4]+(a[3]+3)/4;//这个+3和下面的+8,+35好机智
int b2=a[4]*5+b[a[3]%4];
if(b2<a[2])
ans+=(a[2]-b2+8)/9;
int b1=ans*36-a[6]*36-a[5]*25-a[4]*16-a[3]*9-a[2]*4;
if(b1<a[1])
ans+=(a[1]-b1+35)/36;
printf("%d\n",ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: