您的位置:首页 > 大数据 > 人工智能

HDU Problem - 1789 Doing Homework again【贪心】

2016-07-23 16:45 513 查看

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11352    Accepted Submission(s): 6672

[align=left]Problem Description[/align]
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

 

[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

 

[align=left]Output[/align]
For each test case, you should output the smallest total reduced score, one line per test case.

 

[align=left]Sample Input[/align]

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

 

[align=left]Sample Output[/align]

0
3
5

 
[align=left]WA了无数次之后终于过了。我的思路是按照交作业的最后期限进行升序排列,从第一个开始,每次找最大的加入dn中,如果在最后期限的那天有多个,把最大的加入到dn,其他的如果大于dn中最小的,就把他加入dn,把最小算作扣分,否则对其进行扣分。每次查找时对dn进行排序,好找他的最小值进行替换,这样就可以做到将最大的做完,把较小的加上去。查了无数次bug,对拍了好多次,终于AC了,现在我坚信细心的重要性了。[/align]
#include <cmath>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 1010
#define MAX(a, b)   ((a > b)? a: b)
#define MIN(a, b)   ((a < b)? a: b)
using namespace std;
const int INF = 1e8;

struct node{
int del, red;
}data[MAX_N];

bool cmp(node x, node y) {
if (x.del == y.del) return x.red > y.red;
return x.del < y.del;
}
int dn[MAX_N];
void init() {
for (int i = 0; i < MAX_N; i++) {
dn[i] = INF;
}
}
int main() {
int t, n;
// freopen("data.txt", "r", stdin);
//freopen("1.txt", "w", stdout);
scanf("%d", &t);
while (t--) {
init();
scanf("%d", &n);
// printf("%d ", n);
int ans = 0;
for (int i = 0; i < n; i++) {
scanf("%d", &data[i].del);
// printf("%d ", data[i].del);
}
for (int i = 0; i < n; i++) {
scanf("%d", &data[i].red);
//    printf("%d ", data[i].red);
}
sort(data, data + n, cmp);
int cnt = 0; //用作天数计数
int cnt3 = 0;
for (int i = 0; i < n; i++) {
//如果期限为0,加上
if (data[i].del == 0) {
ans += data[i].red;
continue;
}
int k = i;
bool flag = true;
//如果没有到data[i]规定的最后期限,dn放0
while (++cnt < data[i].del) {
dn[cnt3++] = 0;
}
while (data[i].del == data[k].del) {
if (k == n) break;
sort(dn, dn + cnt3);
if (data[k].del >= cnt && flag) {
dn[cnt3++] = data[k].red;
flag = false;
}
else {
if (data[k].red > dn[0]) {
ans += dn[0];
dn[0] = data[k].red;
}
else ans += data[k].red;
}
k++;
}
i = k - 1;
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  acm 杭电