您的位置:首页 > 其它

HDOJ 1009 FatMouse' Trade (胖老鼠和猫做生意,贪心)

2016-07-23 16:45 323 查看

FatMouse' Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 66563    Accepted Submission(s): 22631

[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.

 

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

 

[align=left]Sample Output[/align]

13.333
31.500

 

[align=left]Author[/align]
CHEN, Yue
 

[align=left]Source[/align]
ZJCPC2004

 

[align=left]Recommend[/align]
JGShining   |   We have carefully selected several similar problems for you:  1050 1005 1051 2037 1052 

参考题意:
就是胖老鼠给小猫 j 单位食物,自己可以得到 f 单位 JavaBean 问最多能够得到多少 JavaBean 。

思路:
按照每一组数据的得到每单位 JavaBean 需要付出多少小猫的食物进行排序。然后就是贪心了。

 参考代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#define MYDD 1103

using namespace std;

struct GUI {
double propo_bean;//可以得到的 javabean
double pay_food;//需要付出的 cat food
double propo;//计算 propo_bean/pay_food 的结果,
//既是得到该房间的 1 单位 javabean 需要的 cat food
} dd[MYDD];

bool cmp(GUI x,GUI y) {
return x.propo>y.propo;
}

int main() {
int m,n;// m : cat food的总数;n :房间数
double ans;
while(scanf("%d%d",&m,&n)&&(m!=-1||n!=-1) )	{
for(int j=0; j<n; j++) {
scanf("%lf%lf",&dd[j].propo_bean,&dd[j].pay_food);
dd[j].propo=dd[j].propo_bean/dd[j].pay_food;
//房间的 1 单位 javabean 需要的 cat food
}

sort(dd,dd+n,cmp);//按照付出与得到的比例由大到小排序

ans=0.0;
for(int j=0; j<n; j++) {
if(m > dd[j].pay_food) {
ans += dd[j].propo_bean;//得到
m -= dd[j].pay_food; //付出后剩下的 cat food
} else {
ans+=m*dd[j].propo;
break;
}

}
printf("%.3lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: