您的位置:首页 > 大数据 > 人工智能

Trailing Zeroes (III)<二分>

2016-07-23 16:35 531 查看
Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero
on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

<pre name="code" class="cpp">#include<cstdio>
long long  qiuling(long long p)//球p的阶乘尾部有几个零
{
long long sum=0;
while(p)
{
sum+=p/5;
p/=5;
}
return sum;
}
int main()
{
int t;
scanf("%d",&t);
long long  cut=0,q;
while(t--)
{
cut++;
scanf("%lld",&q);
long long zuo=1,you=900000000,ans,mid;
while(zuo<=you)//用二分查找
{
mid=(zuo+you)/2;
if(qiuling(mid)>=q)
{
ans=mid;//必须定义一个数来记录mid   如果最后直接输出mid 虽然测试正确但不能AC
you=mid-1;
}
else
{
zuo=mid+1;
}
}
if(qiuling(ans)!=q)
{
printf("Case %lld: impossible\n",cut);
}
else
{
printf("Case %lld: %lld\n",cut,ans);
}
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: